Difference between revisions of "Android Applications"

From IRMAWiki
Jump to: navigation, search
Line 20: Line 20:
  
 
== Compatible devices ==
 
== Compatible devices ==
 +
 +
The minimal requirement to use the IRMA applications is that a device supports NFC and has at least [http://www.android.com/about/ice-cream-sandwich/ Android version 4.0 (Ice Cream Sandwich)]
  
 
{|
 
{|

Revision as of 10:30, 5 December 2013

Contents

IRMA Applications

IRMA Card Management

This application allows a user to manage the attributes stored on the card, inspect the transaction log and various other administrative tasks.

Download

IRMA Card Proxy

This application enables a user to use an NFC-capable Android device as a card reader for on-line IRMA scenarios.

Download

IRMA Verifier

This application allows a relying party to easily verify a predefined attribute. Using the settings menu the verification scenario can be selected. Separate applications are currently available which contain either the data and keys used in the pilot or those used by the demonstration cards. Note: these versions can be installed at the same time.

Download

Compatible devices

The minimal requirement to use the IRMA applications is that a device supports NFC and has at least Android version 4.0 (Ice Cream Sandwich)

Manufacturer Device Status Comments
Google / Samsung Nexus S works
Google / Samsung Galaxy Nexus works
Google / LG Nexus 4 works only with Android 4.4
Google / LG Nexus 5 works
Google / Asus Nexus 7 (2012) works
Google / Asus Nexus 7 (2013) works
LG Optimus L5 works